flutterw:用来下载 Flutter SDK,类似于 gradlew

LyttonNatalie 发布于9天前
0 条问题

flutterw

flutterw is a shell script which downloads and executes the Flutter SDK with the exact version defined in itself. It can keep the flutter sdk version consistent for your co-workers and on the CI servers.

Feature

  • keep the flutter sdk version consistent for your co-workers and on the CI servers.
  • added extra commands like "./flutterw dart" can run a dart command, for example:
./flutterw dart --version
  • support windows os, need run with git bash

Config

  • Config flutter version:
flutter_channel="stable"
flutter_version="1.9.1+hotfix.6"

Run

./flutterw --version

Thanks

https://github.com/LinXiaoTao/flutterw

Contact me:

中文:

flutterw

flutterw 用来下载Flutter SDK,类似于gradlew。通过在脚本内配置特定版本号,使得同一工程的所有开发者或CI服务器(例如Jenkins)使用Flutter的版本一致。

功能

  • 保证所有开发者或CI服务器(例如Jenkins)使用Flutter的版本一致
  • 添加了一些额外的常用命令,如 ./flutterw dart 可以直接运行dart命令:
./flutterw dart --version
  • 支持windows系统,需要在 git bash 环境下运行

配置

  • 配置flutter版本号:
flutter_channel="stable"
flutter_version="1.9.1+hotfix.6"

执行

./flutterw --version

感谢

https://github.com/LinXiaoTao/flutterw

Contact me:

查看原文: flutterw:用来下载 Flutter SDK,类似于 gradlew

  • silverleopard
  • smallrabbit
  • redpeacock
  • brownduck
  • organicrabbit
  • yellowwolf
  • beautifulladybug
需要 登录 后回复方可回复, 如果你还没有账号你可以 注册 一个帐号。